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Introduction 
This document supports the ‘Get & Transform Power Query Workshop for Audit, Tax and Advisory 
Professionals’.  In particular, this document focuses on the artist formerly known as Power Query, 
now known as Get & Transform.   

This session focuses on said Power Query in its Excel form, where I look at the ease with which I can 
extract, clean and manipulate data from a variety of sources.  It is known as an “Extract, Transform 
and Load” tool – or “ETL” for short. 

Power Query is also available in Power BI.  Changes and improvements generally appear in Power BI 
before Excel, and there are more data connectors available.  Since the layout of Power BI is often 
updated, you may find that some screenshots don’t match your screen exactly, but all the 
functionality described here will be available.   

Data is one of the most valuable assets of any business, and Power Query is an invaluable tool to 
turn your data into information.  Let’s get started.  
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Power Query: Getting & Transforming Your Data 
Regular users of Excel are well aware of the possibilities to manipulate and present data that has 
come from a variety of sources.  Getting that data ready for each solution can be time consuming: 
complex solutions can require VBA or SQL expertise, and simple solutions often involve repetitive 
tasks before the data is ready to be uploaded to PivotTables.  

Enter Power Query (alternatively known now as “Get & Transform”), which has been designed for 
Excel users to enable the rapid uploading and cleaning of data without needing to turn (in)to VBA 
and SQL experts.  

Power Query is a free add-in ETL (Extract, Transform and Load) tool for users of Excel 2010 
(Professional Plus with Software Assurance version only) and 2013, where it has its own tab on the 
Ribbon, and is now fully integrated into Excel 2016 onwards and Office 365, where it may be found 
on the data tab under ‘Get & Transform’. 

As shown in Excel 365, Power Query is able to upload from many sources: 
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Having extracted the data from the appropriate source (more on the details of this process later), 
the transformation can take place – cleaning away any unrequired detail, merging where 
appropriate (all without the erstwhile VLOOKUP), and enhancing by calculating and adding new 
columns.  There is even a button to unpivot data! 

 

Whilst the majority of transformations can be done with no formulae or coding, each step is stored 
in M, the language behind Power Query.  For the more ambitious user, M may be used to refine and 
build on what Power Query creates automatically. 

The final step for the ETL tool is to load - to Excel tables, Power Pivot, Power BI – or else just store a 
query for use by other queries,  i.e. a building block that may be re-used.  Since everything is 
recorded in M, you may simply reload to the same destination – simply refresh.  

Please be aware that Microsoft often releases updates, usually on a monthly basis – try searching 
‘updates for Get & Transform in Excel’ to see the latest updates.   

 

Getting Started: Importing Data 

The best way to get to grips with a tool like Power Query is to start with a simple task.  Excel users 
may often need to take data from CSV (comma separated values) files and transform it ready for 
analysis.  Power Query has been designed to assist with this, so let’s see how easy it can be. 

Starting with a new workbook, I locate the ‘Get & Transform Data’ section on the Data tab: 

 

For this example, I am using the ‘From File’ option, and choosing ‘From Text/CSV’: 
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I browse to the location of a simple expense CSV file.   

 

I select the file using the Import button.

 

This screen allows me to specify properties of the CSV file that I am importing from.  The ‘Data Type 
Detection’ allows me to choose whether the algorithms Power Query uses to determine the data 
types are used, and whether to read the whole dataset.  The default is to base the types on the first 
200 rows, which is enough for this short example.  Whilst I have the option to load from this point, 
I’d always recommend the ‘Transform Data’ option to avoid any nasty surprises. 
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Getting Started: Transforming Data 

The Power Query Editor screen shows the table of data as it will be uploaded.  In the ‘Query 
Settings’, the name of the query appears under PROPERTIES and under ‘APPLIED STEPS’, where I can 
see the steps that Power Query has taken automatically.  The source has been identified, the header 
column names have been assumed and the ‘Changed Type’ step sets the detected type for each 
column.  The M code for ‘Changed Type’ is: 

=Table.TransformColumnTypes(#"Promoted Headers",{{"Name", type text}, {"Date", type date}, {"expense 
code", type text}, {"amount", type number}}) 

It is essentially a list of column names and their assigned data types based upon the data that Power 
Query has analysed: 

 Name is type text 
 Date is type date 
 expense code is type text 
 amount is number. 

In this case, all the assumptions look good so I may accept Power Query’s automatic assignment of 
data types. 

I can make any changes to the data, such as changing column names or removing columns.  Selecting 
a column and viewing the ‘Transform’ tab reveals buttons for many of the usual transformations.   
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I can double-click on expense code and rename it to Expense Code.  This creates a new step 
‘Renamed Columns’: 

 

The M code is: 

= Table.RenameColumns(#"Changed Type",{{"expense code", "Expense Code"}}) 

If I rename amount to Amount, Power Query recognises that I am doing and adds the change to the 
existing ‘Changed Type’ step: 

= Table.RenameColumns(#"Changed Type",{{"expense code", "Expense Code"}, {"amount", "Amount"}}) 

A more complex step is to make the Name data appear on each row.  There is a ‘Fill Down’ option 
available if I right-click on the Name column, but it doesn’t seem to do anything! 

 

In order to use the ‘Fill Down’ functionality, the ‘empty’ Name cells that are to be populated must be 
set to null, but currently they are blank.  I need to replace the blanks with null so that I can fill down.  
The option to ‘Replace Values…’ is also on the right-click menu.  The ellipsis (…) indicates that a 
window will appear: 
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I opt to replace blanks (which I just leave empty) with null.  I don’t need the ‘Advanced options’ here. 

 

The ‘Filled Down’ step is from my failed attempt before I set the values to null.  I will delete this 
shortly, but first I ‘Fill Down’ again.  

The steps are generated in the right-hand pane, and we are ready to load to Excel using the ‘Close 
and Load’ button on the ‘File’ tab.  The uploaded table is shown below, and the Workbook query 
window displays the query that generated the data, so that it can be updated and / or refreshed as 
required.  The ‘TABLE TOOLS’ tab opens automatically ready for use in the Excel workbook: 
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This time, the ‘Fill Down’ is successful.  I can delete the first ‘Filled Down’ step now.  I can select or 
hover over ‘Filled Down’, and click on the delete cross that appears next to it: 

 

I am prompted to confirm my action: 

 

Power Query has been improved over time, and copes well with deleting intermediate steps now.  
Previous versions required me to manually change references to previous steps, but this is now 
automated.  If I am at all concerned, I can take a copy of my query before I proceed (more on this 
later).  In this case, I am happy to proceed: 
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Getting Started: Loading Data 

Now I am happy with the data, I can use the ‘Close & Load’ option on the Home tab to load the data 
to Excel: 

 

Choosing ‘Close & Load’ will load my query into Excel as a Table in a new sheet.  As the help message 
implies, choosing ‘Close & Load To…’ will allow me to add further specifications into a dialog.  More 
on this later. 

I am happy to load the data into a new sheet: 

 

The sheet has the same name as the query, and my Table appears, and is given the same name as 
the query (with any spaces converted to underscores).  The query that created the table appears in 
the ‘Queries and Connections’ pane.  Refreshing this query ensures that it is extracting, transforming 
and loading the latest data source.  The original CSV file is not changed by any of the steps I have 
created.  

Let’s look at appending more data… 
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Appending Files 

Whilst it is possible to extract multiple CSV (comma separated values) files at the same time (more 
on this later), imagine a scenario where similar files appear at intervals and need to be added to a 
table.   

In the same workbook, I repeat the process to extract data from a CSV file, and use the same steps 
to transform the data.  This time I have extracted Mary’s data: 

 

I want to add this data to Derek’s data.  I can do this by appending this query to Derek’s query.  On 
the Home tab there is a Combine section where there is an ‘Append Queries’ dropdown: 

 

As the dropdown shows, I can either ‘Append Queries’ where I ‘Append this query to another query 
in this workbook’ or I can ‘Append Queries as New’.  Since the expense files are always required to 
be uploaded together, the ‘Append Queries’ option is fine here. 

 

I don’t need to choose the ‘Three or more tables’ option; I can simply select the other query from 
the dropdown.   
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The data appears in the same query, and a step is created in M code combining the data in the 
current query with the Derek’s expense query that already exists.  The number of columns remains 
the same.  If any columns had been duplicated, then I should check column names are the same 
(including the same case and with no extra spaces) in both queries.  

As before, I can ‘Close & Load’ to see the data in a new Excel sheet: 

 

Further files can be appended using the same method as they arrive.  

If I want to extract similar files at the same time, there is another option: extracting from a folder, 
and that’s next… 
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Extracting from a Folder 

In this example I have 10 expense files in a folder called PQ_StandardExpenses.  In a blank 
workbook, I choose the ‘From File’ Option, and drop down to select ‘From Folder’. 

 

A simple browse window appears, and having chosen the correct folder, the meta data is displayed: 
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At this point, I could choose to combine these files and I’d be done, but editing allows the data to be 
transformed, and some safety features to be added.  

Some kind person has added some excel workbooks in the folder, not to mention a strange file 
extension ‘kat’!  I need to make sure nothing added to the folder in the future will mess up my 
query.  I can also allow for users typing in csv or CSV when they create their files.  I opt to ‘Transform 
Data’: 

 

I start by transforming the Extension data to lowercase.  I select the column and right-click to find 
the ‘Transform’ to ‘lowercase’ option. 

 

Next, I can filter to just get those files with file extension ‘csv’.  At the top of the Extension column 
there is a standard filter arrow: clicking on this reveals a number of options to transform the data in 
the column.   
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I could use the ‘Text Filter’, but instead, I will choose ‘csv’ from the radio list: 

 

This generates a step to filter on ‘.csv’: 

 

The query is now protected from stray workbooks and will include files with .csv and .CSV 
extensions.  Simple! 

In order to transform the data in the files, I need to see the table contents, and not just the 
metadata.  Next to the Content column header is an icon which appears for binary files, and allows 

the binary to be combined – the  icon. 
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Pressing the button with this icon makes the contents of each table appear under the table 
headings:

 

This is just showing me the first file, and I am happy with the layout, so I click OK: 

 

This process has been improved over time, and Power Query creates a ‘Helper Queries’ folder in the 
Queries tab to help to transform my data.  
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In previous versions, I had to promote headings and remove heading rows from each appended file, 
but all of this has been done for me.   I need to do is ‘Fill Down’ on the Name column using the same 
method as before, by replacing blanks with nulls and right-clicking to ‘Fill Down’.  I also rename 
expense code and amount to ‘Expense Type’ and ‘Amount’, so that I will be able to append to other 
expense files with no duplication. 

My data is now ready for me to ‘Close & Load’ to the workbook: 

 

Extracting from a folder is an efficient way to upload multiple expense files in a similar format, but 
what if someone sends in a CSV file that has been configured differently?  We deal with a simple 
example of unpivoting data next… 

 

Unpivoting Data 

Not everyone sticks to the standard format on their expenses, as that would be far too convenient 
for data analysts!   

Let’s imagine PQ_NonStandardExpense_CSV has come in, and it is an expense csv which is not in 
the usual format because John has configured his data ready to create a graph of where his expenses 
go.  Convenient for him, but not so great for appending to the existing expense query: 

 

Luckily, Power Query has a button for this: in order to get this into our required column format I will 
need to unpivot the data.  
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The first step is importing the non-standard expense CSV as I did for the single CSV file earlier: 

 

I browse to the file and select it: 

 

I will choose ‘Transform Data’. 

 

The first step for this example is to remove any unnecessary data – in this case John has added a 
personal expense column which is not required in the model.  However, rather than remove the 
offending Personal column, it is safer to keep the columns that I know I need in order to append this 
query to the other expenses.  I hold CTRL while I select the columns I want to keep.  Then I can right-
click and choose ‘Remove other Columns’.  A tip here is to select and click whilst in the column 
heading, otherwise Power Query can assume I am selecting a value in the column.  
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Name can then be filled down using the same process that I used earlier: I replace the blank values 
with null and then right-click on the Name column and choose to ‘Fill Down’. 

 

I am ready to unpivot process – I select Name and Date as I plan to unpivot the other columns.  In 
the ‘Any Columns’ group on the ‘Transform’ tab there is an option to ‘Unpivot Columns’ – there are 
two options, either unpivot the selected columns, or everything except the selected columns, which 
can save time depending on the proportion of columns that need to be unpivoted. 
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The unpivot options are also available by right-clicking any of the highlighted columns: 

 

One click and everything is unpivoted as required!   

 

The small changes left to do are to transform the unpivoted columns to match the other expenses.  I 
rename the headings by double-clicking and editing.  

The data is then ready to be uploaded or appended to an existing expenses query as covered earlier. 

 

Relationship between Power Query and Power Pivot  

This is relevant to Power BI too.  So far, I have concentrated on how to use Power Query as a 
standalone tool.  In a moment, I will look at extracting data from a table and loading to the Excel 
model.  This will allow the data to be manipulated by another Excel Add-in: Power Pivot.  Therefore, 
now I will take a look at the relationship between Power Query and Power Pivot. 

I have shown that Power Query is a useful ETL (Extract, Transform and Load) tool.  Well thought out 
features allow data to be filtered, manipulated and merged.  In addition to the previous examples 
where I have loaded data into an Excel worksheet, loading to the Excel model allows further 
modelling and analysis by Power Pivot.    

Power Pivot can fine tune the Excel Model and then perform calculations so that the data is ready to 
be displayed in PivotTables, charts or grids, or in a visualisation tool like Power View.  Power Pivot 
can create relationships between tables, and create formulas and KPI’s (Key Performance 
Indicators).  Power Pivot refines and builds on the Excel model created by Power Query.  Next, I will 
describe how to extract a table from a database, transform the data, and load it into the Excel model 
ready for further analysis using Power Pivot.   
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(Data) Model Building 

Up until now, I have concentrated on extracting data from files and folders.  For this example, I will 
extract data from a table in a Microsoft Access database.  Although I could use this data in an Excel 
workbook as in the previous examples, this time I will add the table to the Excel data model, so that 
it can be used by Power Pivot.  

A quick glance at the drop down ‘From Database’ under ‘Get Data’ on the Data tab reveals a large 
selection of different kinds of databases that can be accessed in order to extract data: 

 

Choosing the ‘From Microsoft Access Database’ option allows me to browse for the database that I 
will use.  Having selected my database, the navigator screen lists all the tables in that database.  I 
choose to preview ‘ACCT_Order_Charges’: 
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I choose to ‘Transform Data’.   

 

I select the columns I want to keep whilst holding CTRL and right-click to ‘Remove other Columns’ as 
I did for the CSV example.  
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I can then use the ‘Close & Load’ option from the ‘File’ tab or the ‘Home’ tab: 

 

I must choose ‘Close & Load To…’, which will allow me to specify how I want to load the data. 

 

This gives me the option to ‘Add this data to the Data Model’.  I also choose the ‘Connection Only’ 
option since I don’t need to see the table in the workbook.  Since I have Power Pivot, I can go to 
Power Pivot tab and select the Manage (data model) option; ‘ACCT_Order_Charges’ is visible in the 
‘Workbook Queries’ pane. 

 

Choosing to ‘Manage’ allows me to view the ‘ACCT_Order_Charges’ table in detail, ready to refine 
the data further by adding calculated columns and creating and managing relationships with other 
tables in the model. 
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If I can edit the table in Power Query and Power Pivot, are there any problems to look out for?  The 
good news for Excel 2016 onwards and Office 365 users is that since Power Query has been fully 
integrated into the ‘Get & Transform’ section, there is no choice between using Power Pivot or 
Power Query.  In earlier versions of Excel 2013, and in Excel 2010, it was possible to corrupt the Excel 
model by making some types of changes in Power Pivot.  The current version of Excel 2013 stops me 
from making these changes in Power Pivot.  And that is a good thing. 

Starting with the Excel model I created above, I’ve decided to change the table name to make it 
more user friendly: 

 

Thus, having received the message in the screen shown above, I am directed back to Power Query to 
rename the table.  The reason that I am stopped from changing the name here is that in previous 
versions of Excel 2013 and 2010 users could change the name in Power Pivot which then broke the 
link between Power Query and Power Pivot.  Therefore, there are some actions to be avoided in 
Power Pivot if the Excel model has been created in Power Query: 
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 do not change a table name in Power Pivot 
 do not rename an imported column in Power Pivot 
 do not delete an imported column in Power Pivot. 

Any of these actions could result in a broken link between Power Query and Power Pivot. 

It therefore makes sense to clean up data as much as possible in Power Query, renaming and 
deleting as required.  Although merging some tables and queries in Power Query can be useful to 
avoid having unnecessary tables, don’t try to flatten all the data into one huge table.  One of the 
features of Power Pivot is the ability to manage relationships between tables, allowing keys to be 
constructed as required.  This is vital in creating accurate calculations and useful new columns to aid 
analysis of data.  As with most relationships, Power Query and Power Pivot work well together when 
they are allowed to do what they are best at.   

Next, I’ll take a look at merging queries in Power Query… 

 

Merging Queries 

Power Query allows me to merge tables (known as queries in Power Query), without either the need 
to be an expert on database structure or without having to learn formulae.  I only require two (or 
more) existing queries. 

I have a query ACCT_Order_Charges which I have extracted from a Microsoft Access database, and I 
want to merge data from another table so that I can include a description of the type of items that 
the charges apply to.  

Starting in the workbook containing the ACCT_Order_Charges query, I create a new query.  Since I 
have already made the connection to the database, I can use the ‘Recent Sources’ button on the 
Data tab. 
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I select the database, and the Navigator dialog appears:

 

I select the ‘Transform Data’ option. 

 

I select Item_Key, Item_Group and Item_Name and right-click to ‘Remove other Columns’.  These 
are the fields I will need to merge the data with ACCT_Order_Charges. 
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I do not wish to make further changes, so from the Home tab I select ‘Close & Load to…’ from the 
‘Close & Load’ button: 

 

Note that the Items query appears in the ‘Queries & Connections’ pane, but is not complete yet.  
Having made my selections as shown above, I choose to ‘Load’. 

There are several ways I can access the option to merge my queries.  I can double-click on either 
query to access the Power Query Editor, or I can right-click on one of the queries: 
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The Merge dialog appears where I choose my two queries: 

 

The dropdown at the bottom of the screen allows me to choose how to link the tables.  In this case, I 
choose ‘Left Outer’, as I want all of the ACCT_Order_Charges table and matching data from Items (if 
I had input Items first then I would pick ‘Right Outer’).  This is the point where some understanding 
of the data is required; picking ‘Full Outer’ may lead to duplicates. 

The ‘OK’ button is not enabled yet.  This is because I need to pick the columns to join.  In this case, I 
want to join Item_Key in both tables, so I select this field on each table.  When I select the same 
number of columns in each table, then ‘OK’ is enabled, and the number of connections is displayed: 
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I click OK, and am taken into the Power Query Editor: 

 

Merge1 contains the columns from ACCT_Order_Charges, and a new column called Items.  Note the 
icon next to it with two arrows pointing away from each other: this will expand to show the new 
columns available: 

 

I can uncheck columns that are already in the first table to prevent duplication.  In this case 
description is very similar to Item_Name so I uncheck Item_Name and Item_Key (since I only 
included the key to enable me to link the table data). 

 

I unselect ‘Use original column name as prefix’.  I would only need to choose this option if the table 
already contained a column with the same name.  
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Note that the order of the rows has changed because the non-linked rows which had no item key 
have moved to the bottom.  

 

 I can fix this by sorting on Order_Key and Order_Line_Number.  There is a downward arrow icon 
next to each column heading which I can click and then choose to sort in ascending order. 

 

Having done this for both columns, Power Query combines these sorts into one step.  I also choose 
to rename the table to something more meaningful than Merge1. 

 



 SumProduct Pty Ltd 

 

Page 34 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

I can now ‘Close & Load’ to create a new merged table, which can be used in Excel workbooks and 
the Excel data model.  When merging queries do keep in mind the warnings above; if the queries are 
for use by Power Pivot only, then consider whether it would be more useful to load one merged 
table or separate tables that may be managed in Power Pivot.  However, for creating Excel 
workbooks, merging is a useful way of pulling in data from many tables in order to view the data in a 
single table.  Data may of course come from other external sources.   

Next, I will look at extracting data from a website… 

 

Extracting from a Website 

Whilst Power Query will allow data to be extracted from the web, for many webpages, some 
knowledge of HTML is needed, and even then, a great deal of transformation is often required to get 
the data into a tabular form.  However, if the page uses tables, then the data can be much easier to 
extract.  Today, I show how to extract data from a webpage that holds information in a table.  

For my example, I will use an excellent webpage which provides a list of training events by Excel 
specialists: perhaps it looks familiar? 
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On this page, there is a table of upcoming courses: 

 

I start in the ‘Get & Transform Data’ section on the Data tab, by choosing to get my data ‘From Web’.   

 

The window that pops up gives me a choice of ‘Basic’ or ‘Advanced’ options.  I could have used the 
basic option since my full web page is fairly short, but I have chosen the advanced option to show 
how webpage addresses may be built. 

 

I have chosen to access https://www.sumproduct.com/courses; I can opt to set timeouts if I find I 
am having problems with a particular website, but I will choose not to set any in this example (since I 
know how great this website is!). 
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If I were accessing www.sumproduct.com for the first time, then I would be prompted to confirm 
the authentication options, which default to ‘Anonymous’.  It is possible to see the same 
authentication options from ‘Data Source Settings’ at the bottom of the ‘Get Data’ dropdown: 

 

I select the settings for SumProduct: 
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I have chosen to use the anonymous setting, since the webpage I am viewing does not require any 
password or other security information.  Future queries accessing the same website will use the 
existing authentication settings. 

Once the authentication method has been defined, Power Query links to the webpage and returns 
the recognised content.  

 

The navigator pane shows that Power Query has identified a document and a table.  The document 
highlighted clearly doesn’t show any recognisable data about courses.  More work would be 
required in order to obtain useful information from this.  The table, however, proves more fruitful, 
as shown below: 
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I have a list of courses, and I choose to ‘Transform Data’ ready to load to an Excel workbook. 

 

It all looks good, so I rename the query SumProduct Courses and ‘Close & Load’. 

 

The link to the webpage may be refreshed in the same way as other data sources.  A word of 
caution, however: in this case, I have used a reliable source, which I know will be well maintained, 
and which will not be subject to abrupt format changes without warning.  Using content which I 
have no control over is risky and can lead to bad decisions being taken as a result of using out of 
date or erroneous data.   

 

 

 

 



 SumProduct Pty Ltd 

 

Page 39 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

Introduction to M 

For users already familiar with Power Pivot and Data Analysis eXpressions (DAX, the associated 
programming language), it might seem logical that Power Query would use a similar language and 
perhaps even the same formulae.  Not so.  Power Query has its own language, M, and its own 
formula syntax.   So, having abandoned any expectation of familiarity, I need a good place to start 
looking at M language.  I will create a custom column and look at a formula that can be associated 
with that new column.     

I start out in the worksheet for the merged query I created earlier and open 
ACCT_Order_Charges_with_Group to access the query editor.  On the ‘Add Column’ tab, I choose to 
‘Custom Column’: 

 

The dialog box has a large section for the formula beneath the name I choose for my new custom 
column.  Available columns in the query are shown and double clicking them adds them to the 
formula (or I can select and then choose to ‘Insert’ them). 

Notice the option to ‘Learn about Power Query formulas’ at the bottom of the dialog box.  This is the 
best place to find out what formulae are available in Power Query.  Clicking here will take me to the 
Microsoft help page, which has a links to explain the Power Query M language and the functions 
available.  

Having said that the formulae do not tend to match those for Power Pivot, there are some functions 
that are reassuringly familiar from Excel, as I will show now by concatenating two existing columns. 

I decide to create a column that combines Item_Group and Description by double clicking each 
column (or using ‘Insert’).  I type in an ‘&’ between the columns, which is the same as I would do in 
an Excel formula, and include a ‘/’ to separate the data in the column to make it easier to read: 
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I click ‘OK’ and my custom column is generated, ready to be loaded to my worksheet. 

 

There are other similarities with Excel: the symbols ‘+’, ’-‘, ’*’ and ‘/’ are used for add, subtract, 
multiply and divide respectively too.  

There are however some points to bear in mind when comparing Power Query formulae with Excel: 

 Excel formulae are not case sensitive, but Power Query formulae are (this is a classic gotcha) 
 Excel counts using a base of one [1] ( e.g. the first letter in a string is at position 1), but 

Power Query uses a base of zero [0] (so the same letter would be at position 0) 
 Excel will automatically convert data ( e.g. concatenating a text column to a numerical 

column will work as Excel converts them to text automatically); Power Query will not ( e.g. 
trying to concatenate text to a value will give errors in the new column – the value must be 
converted to text first).  This is why I picked two text columns for my example above.  

If I go to the ‘Advanced Editor’ on the Home tab, I can see all the code for the current query. 
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This allows me to view a short section of M language, which demonstrates some of the M language 
syntax rules: 

The first line of every query must begin with ‘let’: 

let 
    Source = Table.NestedJoin(ACCT_Order_Charges, {"Item_Key"}, Items, {"Item_Key"}, "Items", 
JoinKind.LeftOuter), 
    #"Expanded Items" = Table.ExpandTableColumn(Source, "Items", {"Item_Group"}, 
{"Item_Group"}), 
    #"Sorted Rows" = Table.Sort(#"Expanded Items",{{"Order_Key", Order.Ascending}, 
{"Order_Line_Number", Order.Ascending}}), 
    #"Added Custom" = Table.AddColumn(#"Sorted Rows", "Custom", each [Item_Group] & "\" & 
[Description]) 
in 
    #"Added Custom" 

In this case, I have five lines which refer to steps defining the source of the query (which I can see in 
the ‘APPLIED STEPS’ section in the Power Query Editor) and data manipulation.  Some of the steps in 
the Advanced Editor are preceded by a ‘#’, but more on this in a moment.  The lines are separated 
by a comma (‘,’).  The end of the query is indicated by ‘in’ and a further step: 

 in 
    #"Added Custom" 

This tells Power Query which step to return to once the query has been executed, in this case ‘Added 
Custom’.  The ‘#’ at the beginning of some of the lines is a message to Power Query to ignore the 
spaces in the names ( e.g. in ‘Sorted Rows’).  This is useful to know when creating steps manually. 

The steps are sequential, and need to be linked to the previous step.  Hence, the ‘Sorted Rows’ step 
refers to the ‘Renamed Columns’ step and the ‘Renamed Columns’ step refers to the ‘Expanded 
NewColumn’, etc.  When inserting lines, I must adjust the surrounding lines to make sure the 
sequence is intact, otherwise I will get an error.  Power Query has moved on since it was first 
created, and now if I am working with the Power Query editor, I can use the GUI interface to insert 
steps, and Power Query will automatically adjust the step names on the next step as required. 
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The lines are quite long and can get quite convoluted, so I can edit the format to make it easier to 
read: 

 

I have split the lines up to make them less of a long list of code.  This may be useful when trying to 
keep track of whether all brackets have been closed (and closed in the right place).  I have also 
inserted a single comment by preceding the line with ‘//’, and a section of comments by preceding 
with ‘/*’ and ending with ‘*/’.  Users of earlier versions of Power Query may notice that the ‘token 
comma’ is now not needed after a comment section: do be guided by the syntax checker. 
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The checker is at the bottom of the screen which will warn me if the syntax is wrong and allow me to 
jump to the error. 

 

A more recent development in Power Query is to make the comments visible from ‘APPLIED STEPS’: 

 

 

The next sections are all about building a Calendar query.  The four steps are: 

 Step 1: Create a table called Parameters in an Excel Worksheet to hold the calendar 
boundaries  

 Step 2: Create a function fnGetParameter which uses the calendar boundaries as its 
parameters 

 Step 3: Build the basic dynamic calendar framework 
 Step 4: Add any required calendar columns. 
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Creating a Calendar – Step 1: Creating Parameters 

In a new blank Excel Worksheet, I create a new table with some specific properties.  My table is 
called Parameters and has two columns, Parameter and Value. 

To begin, I will open a new blank Excel worksheet – in the ‘Insert’ Section, there is an option to 
‘Insert Table’ which brings up a ‘Create Table’ dialogue box (CTRL + T is the shortcut).  I choose an 
area that covers two columns and three rows (I chose A7:B9 in the example shown below).  I check 
the box ‘My Table has Headers’ and click OK. 

 

Just as an aside, normally here at SumProduct, we will advocate always starting Tables in cell A1 and 
calling the worksheet the same name as the Table.  I am not going to do that here to show it is not 
necessary, but there is merit in doing this if data is exported to other programs too.  It’s best to give 
data exporting a “helping hand” on occasion. 

Returning to my example, the ‘Table Name’ can be changed in the top left of the screen and must be 
set to Parameters.  Clicking on the column names allows me to set them to Parameter and Value: 
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The parameters the function will be using are Start Date and End Date, and these are the entries in 
my first column.  In the second column I enter the date I wish my calendar to begin at, and a formula 
that will show the last day of the current month.  

Parameter Value 

Start Date 1/1/2016 

End Date  =EOMONTH(TODAY(),0) 

This may look like a long number to begin with: the data format on the column needs to be set to 
Short Date as shown below: 

 

My Parameter table is now ready for the fnGetParameter function: 
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Creating a Calendar – Step 2: Create the fnGetParameter Function  

I choose to create a new blank query by going to the ‘From Other Sources’ section of the ‘Get Data’ 
dropdown and choosing ‘Blank Query’ from the dropdown: 

 

In the ‘Query Editor’ screen, I choose the ‘Advanced Editor’ from the ‘Home’ tab. 

I enter the following M language: 

(ParameterName as text) => 
 let 
ParamSource = Excel.CurrentWorkbook(){[Name="Parameters"]}[Content], 
ParamRow = Table.SelectRows(ParamSource, each ([Parameter]=ParameterName)), 
      Value= 
 if Table.IsEmpty(ParamRow)=true 
  then null 
  else Record.Field(ParamRow{0},"Value") 
in 
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    Value 

I then rename the query fnGetParameter. 

 

When I choose to ‘Close and Load’ from the ‘Home’ tab the new query automatically saves as 
connection only.   Double-clicking on it invokes the function: 

 

Now I have my parameters and a function which will read them, so that I may create my calendar 
framework and add columns to create a useful calendar.  

 

Creating a Calendar – Step 3: Build Framework 

Now I have set up my parameters and created a function to extract the values, I can begin to build 
my calendar.  In the worksheet I created last time, I will start by creating another blank query, 
following the same procedure as before, and this time I will call it Calendar.  The process I follow to 
create my calendar framework is to build a list of dates between the two parameters that I have 
specified.  
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I begin by entering a simple list in the formula bar: 

= {1..10} 

 

This gives a column of 10 numbers, which I can prepare for calendar format by transforming.  Notice 
that Power Query automatically presents me with options for transforming a list. 

In the ‘Convert’ section I choose to convert my list ‘to Table’, and take the default options: 
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In the resulting table I right click my column and ‘Change Type’ to ‘Date’, and then rename my 
column Date. 

 

They may not be current, but they are dates!  Now I need my parameters.  

I choose the ‘Advanced Editor’ from the ‘Home’ section.  The editor shows the lines already created 
as a result of the transforming I have done.  The ‘Source’ step currently shows my original list of 10 
numbers: I need to change the source to look at my parameters instead of 1 and 10.  Therefore, 
after ‘let’ and before the ‘Source’ line, I need to add my parameters, which I will call startdate and 
enddate thus: 

startdate = fnGetParameter(“Start Date”),  
enddate = fnGetParameter(“End Date”),  
 

 

However, if I try this, I get the following error: 

 

This is because I started with a list of numbers and then I tried to use dates instead.  I need to 
express the dates as numbers, so I need to use the Number.From function: 

startdate = Number.From(fnGetParameter(“Start Date”)),  
enddate = Number.From(fnGetParameter(“End Date”)), 
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When I use these definitions instead, my query returns a column of dates: 

 

 

Creating a Calendar – Step 4: Adding More Date Columns 

Although I have a calendar, it is a very basic calendar.  A few more columns would be useful.  For 
this, I am going to repeatedly use the ‘Date’ section of the ‘Add Column’ tab and use the options that 
are shown on the dropdown below: 

 

I choose to add the ‘Year’, ‘Month’, ‘Day’ and ‘Quarter (of Year)’ options.  It doesn’t matter what 
order I create them in as I can drag the columns to change the order: 
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On the ‘Home’ tab, I then choose to ‘Close and Load’ to see that all the Calendar entries have been 
created as I expected.  The entries automatically appear in a separate sheet to my Parameters table: 

 

My calendar is ready for use.   

 

More on Parameters 

Parameters are not just useful for creating Calendars.  In this extended section I look at some other 
uses: 

I am looking at some exam results: 
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I will be grading the results and I will be using this example to explore parameters.  I’ll start by 
extracting my data into Power Query, where I will create the grade column.  To extract my data, I 
choose ‘From Table/Range’ from the ‘Get & Transform’ section of the Data tab. 

 

Conditional Columns 

I have called my query Exam Results.  I will begin by creating a Conditional Column from the ‘Add 
Column’ tab: 

 

I call the new column Grade, and create the grade bands for the results.  Each Clause will look at 
whether the Result ‘is greater than’ a Value, and I will start with the highest grade.  

 

For now, I will be entering values, but I plan to replace this with parameters later. 
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I create a Clause for each band.

 

Note that, if I miss one, I can add it later and then change the order using the menu next to each 
Clause. 
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I click OK to see the new column: 

 

The M code generated for this step is as follows: 

Table.AddColumn(#"Changed Type", "Grade", each if [Result] > 90 then 9 else if [Result] > 
80 then 8 else if [Result] > 70 then 7 else if [Result] > 60 then 6 else if [Result] > 50 
then 5 else if [Result] > 40 then 4 else if [Result] > 30 then 3 else "Ungraded") 

I can change this in the Advanced Editor, which I access from the Home tab.  I want to format it so 
that the boundaries are easier to see.  I can split each step over any number of lines, a comma (,) or 
(as in this case) the ‘in’ statement indicates when the step is complete.  
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Power Query Parameters 

I am now ready to create some parameters to decide the grades.  

To begin with, I will enter these parameters from the ‘Manage Parameter’ option on the Home tab: 
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I opt to create a ‘New Parameter’.  This brings up a dialog: 
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I am going to enter a parameter for each grade.  I call my first parameter P_Grade_9: 
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The ‘P_’ is to indicate it is a parameter.  This will make it easy to spot in the list of queries.  I also 
enter a description.  When I choose the Type, there is no option for percentage, so I make it a 
‘Decimal Number’ instead.  

 

 

 

 

 

 

 

 

 

 



 SumProduct Pty Ltd 

 

Page 59 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

For now, I will allow ‘Any value’.  I will be revisiting the ‘Suggested Values’ dropdown for this 
example later.  

 

To complete this parameter, I enter a ‘Current Value’ of 90.  If I were to click ‘OK’ at this point, the 
parameter would be created, and I would automatically exit the dialog: 

 

I can see the parameter in the Queries panel.  If the parameter is selected, then I can edit the 
‘Current Value’ if I wish.  The ‘Current Value’ also appears next to the parameter in brackets ‘(90)’ so 
that I can always see what it is set to in the Queries panel.  
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If I want to create multiple parameters, then I can stay in the ‘Manage Parameter’ dialog by clicking 
‘New’ instead of ‘OK’ when I have finished each parameter: 

 

Note that since my parameters are similar, I can also copy and paste or create Duplicates: 

 

This is fine, as long as I remember to change the name, description and ‘Current Value’.  Do not 
create a ‘Reference’.  This would return the ‘Current Value’ of the parameter: 

 

The icon next to P_Grade_8 (2) indicates a number.  Note also that the ‘(2)’ in this case is created 
because there is already a P_Grade_8 and is not the value! 
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I now have all my parameters ready for the next step: 

 

I can now edit the original query using the Advanced Editor, which I access from the Home tab: 
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I change the M code in the ‘Added Conditional Column’ step from: 

Table.AddColumn(#"Changed Type", "Grade", each  
        if      [Result] > 90 then 9  
        else if [Result] > 80 then 8  
        else if [Result] > 70 then 7  
        else if [Result] > 60 then 6  
        else if [Result] > 50 then 5  
        else if [Result] > 40 then 4  
        else if [Result] > 30 then 3  
        else "Ungraded") 

to  

Table.AddColumn(#"Changed Type", "Grade", each  
        if      [Result] > P_Grade_9 then 9  
        else if [Result] > P_Grade_8 then 8  
        else if [Result] > P_Grade_7 then 7  
        else if [Result] > P_Grade_6 then 6  
        else if [Result] > P_Grade_5 then 5  
        else if [Result] > P_Grade_4 then 4  
        else if [Result] > P_Grade_3 then 3  
        else "Ungraded") 

I can use the Intellisense to make sure I enter the correct name for each parameter: 
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I also rename the step to ‘Assigned Grade’: 

 

 

I click ‘Done’ to make sure that the query still works as I expect: 
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Using Defined Names as Parameters 

Whilst I can change these parameters in Power Query, I’d now like to have parameters that I can 
change from Excel.  On a new Excel Sheet, I have some data for the thresholds: 

 

 

I start by defining a Name for the first threshold.  I can do this by selecting the cell and right-clicking: 

 

I define the Name to be ‘Grade_9’: 
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I can now see this in Power Query.  In the Power Query Editor, I create a new Blank Query.  I can do 
this by right-clicking in the Queries pane (this is one of several methods to create a Blank Query): 
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In my Blank Query, I enter the following M code: 

= Excel.CurrentWorkbook() 

This will show me what is in the current Excel Workbook: 

 

There is the Grade_9 I created.  The value will be in the ‘Table’ next to it.      

I filter Name to get just the ‘Grade_9’ row: 

 

This gives me just one table: 

 

I click on the green ‘Table’. 
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I now have the value of Grade_9 in the column.  I can remove the ‘Changed Type’ step and right-click 
and drill down on the value. 

 

This gives me the value, and I now rename my query DP_Grade_9: 

 

Since this query returns a value, the icon next to it indicates a whole number: 

 

Note that when I ‘Close & Load’ my queries to Excel, I should make sure that DP_Grade_9 is set to 
‘Connection Only’: 
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This is a default for queries created as Parameters in Power Query, but not for DP_Grade_9, as it has 
been created from a query.  This brings me to another point.  I right-click on DP_Grade_9 in the 
Queries pane.  There is an option to ‘Convert to Parameter’ but it is greyed out.   

 

 

Whilst the final result of my query is a single value, I am not allowed to convert it.  This option is only 
available if I create a very simple query which equals a value.  I can create a new Blank Query to 
demonstrate this by right-clicking in the Queries pane: 

 

I create a query which is set to a single text value: 
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The M code I used to create this is simply: 

= “This can be converted to a parameter” 

When I right click on this query in the Queries pane, 

 

I can ‘Convert to Parameter’ and it looks just like the other ‘P_Grade…’ parameters that I created: 

 

 

 

 

 



 SumProduct Pty Ltd 

 

Page 70 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

I would like this to be available for queries like DP_Grade_9 too, so that I could have the current 
value in brackets and the ability to select it as a parameter from other functions.  However, this is 
not an option.  I suspect this is because the query is converted to Metadata, as indicated by the 
Advanced Editor view of I am a parameter: 

 

The previous source step is no longer available.  This would imply that I can’t keep the previous steps 
of DP_Grade_9 and convert it to a parameter.  I’ve seen this question on forums, and this is my 
conclusion! 

I now define names for all the cells that I want to use as parameters: 
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If I go to the DP_Grade_9 query in the Power Query Editor, I can view the Source step: 

 

I ‘Refresh Preview’, using the option on the Home tab: 

 

I notice that the other named cells now appear: 
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I can create a duplicate of DP_Grade_9: 

 

I can use this as a template to create the other queries: 

 

I have renamed the duplicate query, and I click on the cog next to ‘Filtered Rows’ to amend the value 
of Name selected to ‘Grade_8’.  Note that the step ‘Grade_9’ will also need to be edited, as I will see 
as soon as I click OK and move to that step. 
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This step is trying to expand the Content column which corresponds to the Name ‘Grade_9’.  The M 
code is: 

= #"Filtered Rows"{[Name="Grade_9"]}[Content] 

I can change this to: 

= #"Filtered Rows"{[Name="Grade_8"]}[Content] 

 

I have the correct result, but I should also right-click on the step and change the name to avoid 
confusion: 
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I have completed this query: 

 

I repeat this process for the other named cells: 

 

I will now apply these parameters to the Exam Results query and check that any changes to the 
Excel cells affect the outcome of the query. 

I now return to the Exam Results query. 
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The easiest way to change the query to use the Excel controlled parameters is by editing in the 
Advanced Editor, which I can access from the Home tab: 

 

The ‘Assigned Grade’ step is changed from: 

#"Assigned Grade" =  
    Table.AddColumn(#"Changed Type", "Grade", each  
        if      [Result] > P_Grade_9 then 9  
        else if [Result] > P_Grade_8 then 8  
        else if [Result] > P_Grade_7 then 7  
        else if [Result] > P_Grade_6 then 6  
        else if [Result] > P_Grade_5 then 5  
        else if [Result] > P_Grade_4 then 4  
        else if [Result] > P_Grade_3 then 3  
        else "Ungraded") 

to 

#"Assigned Grade" =  
    Table.AddColumn(#"Changed Type", "Grade", each  
        if      [Result] > DP_Grade_9 then 9  
        else if [Result] > DP_Grade_8 then 8  
        else if [Result] > DP_Grade_7 then 7  
        else if [Result] > DP_Grade_6 then 6  
        else if [Result] > DP_Grade_5 then 5  
        else if [Result] > DP_Grade_4 then 4  
        else if [Result] > DP_Grade_3 then 3  
        else "Ungraded") 
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This works because each ‘DP_’ query represents one value: 

 

 

This currently has no effect on the results of the query, since the values are the same: 
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However, it does have an effect on the screen accessed by clicking on the cog (gear icon) next to the 
‘Assigned Grade’ step: 

 

Note that I cannot view the Value column now.  Any changes must be made directly to the M code, 
either from the Advanced Editor or the Formula Bar: 

 

 

Back in Excel, if I change the Named cell Grade_3 from 30 to 20 percent, the outcome will change 
when I refresh the Exam Results query: 
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If I go back to Exam Results and view all the data, I can see that everyone has passed now! 

 

Using Parameters as Locations 

However, I now want to store the grading bands in a separate workbook away from the exam 
results. 

 

Back in my original workbook, I need to extract the data.  I can do this by creating a new query from 
the ‘Get Data’ dropdown in the ‘Get & Transform’ section of the Data tab.  Note that to extract data 
‘From Workbook’, the Excel file I am extracting from must not be open. 
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In the dialog, I find the workbook I wish to use: 

 

I can then choose to ‘Import’. 

 

  



 SumProduct Pty Ltd 

 

Page 80 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

In the Navigator dialog, I can see the Named Cells and the ‘Parameters’ Sheet.  I select Grade_9: 

 

I plan use to this as my base query.  I opt to ‘Transform Data’: 

 

I am interested in the Source step: 

 

The Source step points at the Excel file I have created.  To reduce future maintenance, and to add 
flexibility I am going to create a base query which only includes the Source step, and then I am going 
to use a parameter to point to the file location.  If I have a base query, then any changes I make to 
the Source step only need to be made once.  I delete the other steps and call the query ‘Base 
Query’: 



 SumProduct Pty Ltd 

 

Page 81 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

 

I create a new Parameter from the ‘Manage Parameters’ option on the Home tab: 

 

I call the new Parameter FilePath: 

 

I define the type as ‘Text’ and enter the ‘Current Value’ as the location of the external workbook that 
contains the grading bands.  Having created the FilePath parameter, I return to Base Query.  For me, 
the M code for the Source step is: 

= Excel.Workbook(File.Contents("C:\Users\kathr\OneDrive\Documents\SUMPRODUCT\PQ Blog\Blog 
270 Exam Grade Bands.xlsm"), null, true) 
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I am going to replace the path with the FilePath parameter: 

= Excel.Workbook(File.Contents(FilePath), null, true) 

This is easier to read, and now I can change the path by changing the FilePath parameter. 

 

 

I can now select Base Query in the Queries panel and right-click to create reference queries which 
will become the new grade band Parameters: 

 

I rename the first new query EDP_Grade_9.  The Source step points to Base Query.  I can click on the 
‘Table’ text next to Grade_9 to expand the data for that row: 
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This gives me the data for Grade_9 from the workbook, and I can right-click and drill down to the 
value: 

 

This gives me the first parameter: 

 

I can then make more references of Base Query and repeat this process to get the other 
‘EDP_Grade_’ parameters.    

 

I can go back to the Exam Results query and use these parameters.  



 SumProduct Pty Ltd 

 

Page 84 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

 

I showed earlier that it is not possible to edit using the cog next to the ‘Assigned Grade’ step to 
change the parameters, as they are not shown in the dialog unless they are true Power Query 
parameters.  I also looked at the difference between Power Query parameters and other queries 
that can be used as parameters. 

I use the Advanced Editor, available on the Home tab, to change the M code: 

 

I change the ‘Assigned Grade’ step from this:  

#"Assigned Grade" =  
    Table.AddColumn(#"Changed Type", "Grade", each  
        if      [Result] > DP_Grade_9 then 9  
        else if [Result] > DP_Grade_8 then 8  
        else if [Result] > DP_Grade_7 then 7  
        else if [Result] > DP_Grade_6 then 6  
        else if [Result] > DP_Grade_5 then 5  
        else if [Result] > DP_Grade_4 then 4  
        else if [Result] > DP_Grade_3 then 3  
        else "Ungraded") 

to this: 

#"Assigned Grade" =  
    Table.AddColumn(#"Changed Type", "Grade", each  
        if      [Result] > EDP_Grade_9 then 9  
        else if [Result] > EDP_Grade_8 then 8  
        else if [Result] > EDP_Grade_7 then 7  
        else if [Result] > EDP_Grade_6 then 6  
        else if [Result] > EDP_Grade_5 then 5  
        else if [Result] > EDP_Grade_4 then 4  
        else if [Result] > EDP_Grade_3 then 3  
        else "Ungraded") 

This has no immediate effect on the results of the query: 
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To show how FilePath allows me to point to another workbook, I have another workbook where I 
have the same Named Cells for grading bands set up.  You should note that I must close the Power 
Query Editor in the workbook containing Exam Results before I can edit another workbook, so I 
‘Close & Load To’ and choose ‘Connection Only’ for the new ‘EDP_Grade_’ queries and Base Query: 
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The new workbook I have created has different values for the grading bands: 

 

The workbook also has a different name and is located in a different folder. 

I close the new workbook, and go back to the workbook containing the Exam Results query, where I 
select the FilePath parameter in the Queries pane, and use the ‘Manage Parameter’ button to access 
the dialog: 
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I change the ‘Current Value’ to the new workbook name and location:  

 

When I go back to the Exam Results query, the results have changed: 

 

The results have changed, and it’s not looking good for the class! 

Note that if users of the workbook containing Exam Results needed to maintain the FilePath 
parameter without editing in Power Query, I could link FilePath to a Named Excel Cell in the 
workbook as I have done for the ‘DP_Grade_’ and ‘EDP_Grade_’ parameters.  
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Importing from PDF Files 

This example will allow me to look at both importing PDF files and splitting columns. 

Business is doing well, and the UK division of my company has plans to expand the workforce.  I have 
a PDF file, with data for 10 stores.  The information could change for any of those stores, and the 
way that the information is given is similar to the following: 

 

or maybe like this: 

 

or even like this: 

 

 

My goal is to get all this information into one table. 

Somewhere in the middle of my data, I have some text, which although very useful to the company, 
is no help to me. 

‘There may be plans to build a further store which would require a new workforce, but planning 
permission has not been granted.  Also, we would like to see the Projected Pay increases on the 
report.’ 

This could be added to, reduced or removed.  

 

However, there is also another table, which I do wish to extract, although not in its current form 
(that would be too easy!). 
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This means I don’t know how many pages are in the PDF.  I would normally expect to see data for 10 
stores, and they are all split into three [3] pay scales. 

I start in an empty Excel Workbook, in the ‘Get and Transform’ section of the Data tab, where I will 
use ‘Get Data’ and then ‘From File’, where I may choose ‘From PDF’. 
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This allows me to browse to choose the PDF I want to extract.  I am then presented with the 
following dialog: 

 

This is my first decision: I need to know whether to pick tables or pages.  The best way to decide this 
is to look at what is in them by selecting one of them for preview. 
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I skip to the end of the content list, and look at one of the tables: 

 

Not much in there, do I really need to get every table?  There’s not even a way to link this to a store. 

  



 SumProduct Pty Ltd 

 

Page 92 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

I look at what is in the pages: 

 

Definitely more data, and stores are also included.  I can select multiple items, but do I select all the 
pages?   What if there are more next time? 

There is an easier way.  If I select the folder icon, I have other options… 

 

I can ‘Transform Data’.  This means all the data in the folder will be loaded into Power Query.  This is 
exactly what I want. 



 SumProduct Pty Ltd 

 

Page 93 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

  

 

Here it is.  All the tables, and all the pages.  The M code for this is: 

= Pdf.Tables(File.Contents("FileLocation\Blog 250 Sample PDF.pdf"), [Implementation="1.3"]) 

FileLocation is where I have stored the file on my PC, and ‘Blog 250 Sample PDF’ is the name of the 
file.  

This is using the M function Pdf.Tables(): 

Pdf.Tables(pdf as binary, optional options as nullable record) as table 

This returns any tables found in pdf.  An optional record parameter, options, may be provided to 
specify additional properties.  The record can contain the following fields: 

 Implementation: the version of the algorithm to use when identifying tables.  Old versions 
are available only for backwards compatibility, to prevent old queries from being broken by 
algorithm updates.  The newest version should always give the best results.  Valid values are 
"1.3", "1.2", "1.1", or null 

 StartPage: specifies the first page in the range of pages to examine; the default value is one 
[1] 

 EndPage: specifies the last page in the range of pages to examine.  The default value here is 
the last page of the document 

 MultiPageTables: controls whether similar tables on consecutive pages will be automatically 
combined into a single table.  Here, the default value is true 

 EnforceBorderLines: controls whether border lines are always enforced as cell boundaries 
(when true), or simply used as one hint among many for determining cell boundaries (when 
false).   The default value here is false. 

This explains where [Implementation="1.3"] comes from.  It is the algorithm version, and appears to 
be the latest version, which is reassuring.  
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So back to my extracted data; I know I want the page data, so I can filter the Id column to get 
everything beginning with ‘Page’: 

 

This gives me just the pages.  I only need the Data column now, so I select it and opt to ‘Remove 
Other Columns’. 

 

I can then expand the data, which extracts to columns 1 to 7: 
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The key to making my transformations as immune to change as possible is to keep the data I need 
rather than delete the data I don’t.  Looking at the columns, the easiest way to see if there is any 
useful data in there is to use the filter icon; Column1 is clearly very useful. 
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However, Column8 is not: 

 

However, rather than delete Column8, I should keep what I need.  On the Home tab, there is an 
option to ‘Choose Columns’: 

 

I can use this to specify columns I want to keep.  It’s much easier than selecting them all for large 
tables! 
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I choose to select the first seven [7] columns. 

 

I can see that the heading data from the tables is in Column1, which suggests that transposing my 
data would be useful.  I can do this from the Transform tab. 

 

This swaps the rows and the columns and is much closer to the format I want to see. 
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I can check the data in my columns again to see which ones I want to keep.  However, it is clear that 
this time the column names will change with the extra text that is present in my source data. 

 

Before I decide which columns to keep, I need some way of identifying them.  I will promote the first 
column to the column headings, which I can do from the Transform Tab. 

 

I choose ‘Use First Row as Headers’: 

 

Power Query has created a ‘Changed Type’ step, but this references column names, so I delete it.  I 
can pick the columns I want to keep in the same way as I did earlier. 
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I have the data I want to keep, but there are two tables in here: the store data and the pay scales. 

 

I can keep this query, which I will call All Data, and make Reference queries: one for the store table 
and one for the pay scales table.   I can create reference queries from the ‘Home’ tab. 

 

I call this Reference Query Pay Scales. 

 

I also create another Reference Query, Stores. 

I start with Pay Scales. 

 

I start by keeping the columns I will be needing for this table. 
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This means I can concentrate on the data I need to transform for this table. 

 

Having checked the data, I actually only need the pay scale columns, so I select them whilst holding 
down the CRTL key and click on ‘Remove Other Columns’. 
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Power Query incorporates this into the existing ‘Remove Other Columns’ step. 

 

I can remove empty rows from the Home tab. 

 

I can now look at how to transform my data from this into a useful table. 
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Transposing Data 

I want to transpose the data, but if I do this with some of the data I need in the column headings, I 
will lose it.  First, I need to demote the column headings so that I have the information in a row.  I 
can do this from the Home tab. 

 

This creates a ‘Change Type’ step which I delete as I am not ready to decide column types yet.  I am 
now ready to transpose my data, using the option on the Transform tab. 

 

My data is starting to take shape. 

 

I can rename the headings. 
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Splitting Columns 

I want to show a start and end salary, rather than have the information in one column.  I can split the 
Salary column from the Transform tab. 

 

From the dropdown, I choose to split ‘By Delimiter’; this brings up a dialog. 

 

I choose to split by space at each occurrence of a space, because this will give me a column with the 
lower and upper limit. 

 

I delete the automated ‘Changed Type’ step again.   I don’t need Salary.2, so I can remove this.  As 
usual, I do this by selecting the columns I want to keep and ‘Remove Other Columns’. 
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I want Salary.1 and Salary.2 to be numeric columns, so I need to remove the £ signs.  I can do this by 
selecting the columns and replacing £ with blank.  I start by using ‘Replace Values’ on the Transform 
tab. 

 

This provides a dialog where I can enter the details. 

 

This will remove the £ signs. 

 

Next, I change both columns to whole numbers.  I can do this from the Home tab or the Transform 
tab, or by using the right-click menu, and changing the data type. 



 SumProduct Pty Ltd 

 

Page 105 of 126                                                                         © SumProduct Pty Ltd 2009 - 2024 

 

I get an error, but I can use ‘Replace Values’ again; this time, I choose ‘Replace Errors’. 

 

I want to replace it with null, not zero [0], since zero is the starting point for ‘Pay Scale A’. 

 

Next, I need to transform the Percentage Increase column.  If I make it the data type Percentage, I 
will get values of over 100: I need to divide the values by 100 first, which I can do from the 
Transform tab, but first I change the data type to ‘Decimal Number’.  This will allow me to access the 
‘Standard’ dropdown. 
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I choose ‘Divide’ and enter 100 in the dialog. 

 

I can now set the correct data types for all of the columns. 

 

I rename the salary columns, and my table is ready to ‘Close & Load’.  
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Next, I turn to the Stores table. 

 

I have 10 stores in my table, and I need to perform the same transformations for each one.  The first 
step I will take is to merge the columns I need for Store 1.  I select Store 1, Pay Scales and 
Workforce expansion whilst holding down the CTRL key.  When I right-click, I have the option to 
‘Merge Columns’. 

 

Clicking on this option reveals a dialog: 

 

I choose not to use a separator, since I can split by non-numeric and numeric characters later.  I want 
to call my new column Store 1, but Power Query won’t let me do this as this is one of the names of 
the original columns, so for now I take the default Merged. 
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I can adjust the step created from: 

Table.CombineColumns(Table.TransformColumnTypes(Source, {{"Store 1", type text}}, "en-
AU"),{"Store 1", "Pay Scales", 
"Workforce#(lf)expansion"},Combiner.CombineTextByDelimiter("", QuoteStyle.None),"Merged") 

to: 

Table.CombineColumns(Table.TransformColumnTypes(Source, {{"Store 1", type text}}, "en-
AU"),{"Store 1", "Pay Scales", 
"Workforce#(lf)expansion"},Combiner.CombineTextByDelimiter("", QuoteStyle.None),"Store 1") 

This is then accepted with no issues: 

 

I repeat this for the other stores. 
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I could keep working on all the stores together, but it would soon become a large table.  Instead, I 
am going to work on the stores separately.  Before I do this, I need to make sure that the store name 
is included in the data, so I demote headers using the option from the Transform tab: 

 

My data is now safely stored in the rows, and I can create a query from a column.  I right-click with 
Column1 selected: 
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This creates a new List Query. 

 

I will rename my List Query to Store 1 to reflect the data. 

 

What I want now, is to create a series of steps that will work on any of the stores.  I need a function.  
I start by taking a reference copy of Store 1. 

 

I call my new query fn_store. 
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The first step is to convert this list to a table.  I can do this from the List tab or I may otherwise right-
click. 

 

A dialog appears where I shall accept the defaults: 

 

This gives me access to the other tabs. 

 

I start by promoting the first row to headers using the option on the Transform Tab. 
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I am ready to create the transformations required and convert this query.  I start by getting rid of 
any empty rows.  I can do this by using ‘Remove Blank Rows’ from the Home tab: 

 

This simplifies my table: for this store it is one row, but for other stores there may be more. 

 

I need the store information to be a separate column.  I can do this by employing the ‘Unpivot 
Column’ feature from the Transform tab. 

 

I now have a column with the store data, and one for the pay scales and percentage increase of 
workforce.  I will rename these columns later. 

 

I need to keep in mind that this function needs to cope with the data for all the stores.  This means I 
need to carry out some replacements: 

 ‘All’ needs to be replaced by ‘A,B,C’ 
 ‘ and ‘ needs to be replaced by ‘,’ 
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I can then use comma (,) as my delimiter to split up the pay scales.  I begin with ‘Replace Values’ on 
the ‘Transform’ tab, or else by right-clicking: 

 

First I replace ‘All’: 

 

 

Then I replace ‘ and ‘: 
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My data is now ready to be split:  

 

I am going to split the column into pay scales and increase percentage.  I can do this by right-clicking, 
and choosing to ‘Split Column’ ‘By Non-Digit to Digit’: 

 

This gives me an extra column. 
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Now I can split up the pay scales: I will do this using Comma as a Delimiter, and I will choose to ‘Split 
into Rows’ in the advanced options. 

 

This gives me more rows: 

 

I keep the automated ‘Changed Type’ step and rename the columns. 
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My query is ready to be converted to a function.  I need to parameterise, so I view the M code in the 
Advanced Editor, available from the Home tab. 

 

The only line I need to change is the Source step.  I am going to introduce a parameter p_store, 
which will receive any of the store columns as a list.  The M code before the ‘let’ statement will be: 

(p_store as list) => 

and the Source step will change from: 

Source = #"Store 1", 

to: 

Source = p_store, 
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As soon as I click ‘Done’, Power Query recognises that my query is now a function. 

 

It is prompting me for a column (field).  This means that this function will now create a table from 
any of the store columns in the Stores query. 
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I can test the function on Column1: 

 

Invoking this query will give me a table: 

 

In the Stores query, I need to make sure I only have the columns I need.  To do this, I will remove the 
‘Demote Headers’ step.  I can reapply it before I invoke the function. 
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This means I have the store names in the headings to choose: 

 

This gives me the store columns, and I can demote the headers again: 
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Stores is ready to use as the Source for fn_store.  I go back to fn_store: 

 

I need to provide a column from the Stores query. 

 

I use Column1: 
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Invoking this query will give me a table: 

 

I rename this table Expansion by Store.  I am going to use the M code already generated as a basis 
for this query. 
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I take the M code created for Column1, and replicate it for 10 columns.  I have renamed the steps to 
make it clear what I am planning.  I will rename the final ‘in’ statement when I have finished: 

I 
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I have created a table for each store; now I just need to append them.  The M code function to 
append is: 

Table.Combine({table1, table2,….}).   

I add this line to the M code in the Advanced Editor. 

 

I click ‘Done’ to see the results: 
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I have the results in the format I wanted for all stores.  I can now ‘Close & Load’.  I will choose ‘Close 
& Load to…’ so that I can load to ‘Connection Only’ to begin with to avoid loading all queries. 

 

I can then right-click on the queries I want to load, and position them together: 

 

I load the tables onto a worksheet: 
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I check the data types and the report is ready. 
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Further Reading 

The course may consider topics not covered in this document.  Moreover, you may wish to learn 
more.  SumProduct presently has weekly blogs on Power Query which may be found here: 

https://www.sumproduct.com/blog 

Past articles may be located here:  

https://www.sumproduct.com/thought/power-query-blog-series 

Find out more at contact@sumproduct.com or training@sumproduct.com as required.  We are 
happy to help! 
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